KubePi LoginLogsSearch 未授权访问漏洞(CVE-2023-22478)

威胁等级
中危
漏洞分类
认证绕过/未认证
影响资产分类
应用服务
检索条件
游客用户没有权限查看,请登录
DVB
DVB-2023-4288
CVE
CVE-2023-22478
CNVD
-
CNNVD
-

漏洞描述

KubePi 是一个现代化的K8s 面板。 KubePi 允许管理员导入多个Kubernetes 集群,并且通过权限控制,将不同cluster、namespace 的权限分配给指定用户。KubePi LoginLogsSearch 方法下的接口存在未授权访问漏洞,攻击者通过漏洞可以未授权获取用户的登录日志信息,进一步爆破用户

漏洞详情

游客用户没有权限查看,请登录

修复建议

请关注厂商的修复版本,并及时更新到最新版本.

POC下载

环境验证

joinia

历史积分:2925
提交POC:399